Welcome to Our Dreambox World - Japhar Sim - SuperSim
Forum Stats
10857 Members
230 Forums
7252 Topics
21927 Posts

Max Online: 4756 @ 02/20/20 11:12 PM
Newest Members
notlima, gizmo, Janx, minoas1960, kuanza
10857 Registered Users
Who's Online
11 registered (Admin, Toysoft, camelo, balex1, DNA64, Emosim, bitgames, robi, leovanderplaat, drator, hamdy), 176 Guests and 315 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Top Posters
Admin 9140
Toysoft 2470
satsedhu 1424
fairbird 739
ludo19 442
Top Posters (30 Days)
satsedhu 33
Admin 27
Anton70 14
Toysoft 14
Kenuser 9
April
M Tu W Th F Sa Su
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30
Topic Options
#23192 - 03/16/21 11:58 PM Openvpn client too old on latest japhar openpli
Kenuser Offline
VIP Japhar
newbie

Registered: 10/21/17
Posts: 28
Hi,

I installed an openvpn server to linux pc (vers. 3.0)
The problem is that the version of openvpn client for dm500hd and dm800se from feed is "2.3.9" which is not compatible with the server (tls-crypt unsupported).
Otherwise from zgemma feeds is available the version "2.4.3" which run ok.

Question: where to find openvpn client "2.4.3" for japhar dm500hd and dm800se openpli-7star images?
_________________________
Obsolete: Pioneer ECT-1530 - Kenwood DTF-103 - Sim2 SMB2700 - Philips 6072 - Humax 5400S - Dreambox 500S - NC+ 5800s BXZB E2

Dreambox DM500HD sim Japhar
Dreambox clone DM800HD sim 2.1
Estarbox DM800SE HD sim Japhar
Zgemma H9s

Top
#23193 - 03/17/21 12:41 AM Re: Openvpn client too old on latest japhar openpli [Re: Kenuser]
Admin Online   content
Japhar Member
Carpal Tunnel

Registered: 10/19/10
Posts: 9140
You need to upgrade to the new OpenPLi 8.0star images (openvpn 2.5.0 is built-in or to be installed from the feeds),

Admin


Attachments
OpenPLi_8.0star_openvpn_2.5.0.rar (3 downloads)

_________________________

Top
#23194 - 03/17/21 01:33 AM Re: Openvpn client too old on latest japhar openpli [Re: Admin]
Kenuser Offline
VIP Japhar
newbie

Registered: 10/21/17
Posts: 28
thank you for reply and attachment. Can install this ipk to 7.2star?
_________________________
Obsolete: Pioneer ECT-1530 - Kenwood DTF-103 - Sim2 SMB2700 - Philips 6072 - Humax 5400S - Dreambox 500S - NC+ 5800s BXZB E2

Dreambox DM500HD sim Japhar
Dreambox clone DM800HD sim 2.1
Estarbox DM800SE HD sim Japhar
Zgemma H9s

Top
#23196 - 03/17/21 09:41 AM Re: Openvpn client too old on latest japhar openpli [Re: Kenuser]
Admin Online   content
Japhar Member
Carpal Tunnel

Registered: 10/19/10
Posts: 9140
It's highly improbable (due to libraries that on OpenPLi 8.0star were upgraded to newer versions), but I included it so you can still try.

Admin
_________________________

Top
#23198 - 03/17/21 10:14 AM Re: Openvpn client too old on latest japhar openpli [Re: Admin]
Kenuser Offline
VIP Japhar
newbie

Registered: 10/21/17
Posts: 28
Code:
root@dm800se:~# opkg install /tmp/openvpn_2.5.0-r0_mips32el.ipk

Collected errors:
 * Solver encountered 1 problem(s):
 * Problem 1/1:
 *   - nothing provides libc6 >= 2.30 needed by openvpn-2.5.0-r0.mips32el
 * 
 * Solution 1:
 *   - do not ask to install openvpn-2.5.0-r0.mips32el


can you provide libc6 library >= 2.30 please?
_________________________
Obsolete: Pioneer ECT-1530 - Kenwood DTF-103 - Sim2 SMB2700 - Philips 6072 - Humax 5400S - Dreambox 500S - NC+ 5800s BXZB E2

Dreambox DM500HD sim Japhar
Dreambox clone DM800HD sim 2.1
Estarbox DM800SE HD sim Japhar
Zgemma H9s

Top
#23199 - 03/17/21 10:24 AM Re: Openvpn client too old on latest japhar openpli [Re: Kenuser]
Admin Online   content
Japhar Member
Carpal Tunnel

Registered: 10/19/10
Posts: 9140
This is a big part of the image, that's in fact the jump from 7.x images to 8.0 images.

So you need to install the new OpenPLi 8.0star, as the libc has roots everywhere in all the image/code.

Admin
_________________________

Top
#23201 - 03/17/21 10:31 AM Re: Openvpn client too old on latest japhar openpli [Re: Admin]
Kenuser Offline
VIP Japhar
newbie

Registered: 10/21/17
Posts: 28
ok thanks
_________________________
Obsolete: Pioneer ECT-1530 - Kenwood DTF-103 - Sim2 SMB2700 - Philips 6072 - Humax 5400S - Dreambox 500S - NC+ 5800s BXZB E2

Dreambox DM500HD sim Japhar
Dreambox clone DM800HD sim 2.1
Estarbox DM800SE HD sim Japhar
Zgemma H9s

Top
#23206 - 03/18/21 01:07 AM Re: Openvpn client too old on latest japhar openpli [Re: Kenuser]
Kenuser Offline
VIP Japhar
newbie

Registered: 10/21/17
Posts: 28
Hi,

I installed OpenPLi 8.0Star 20210311 on DM800HDse. Openvpn 2.5.0 is not built-in and from feeds give error with dependencies, so I installed from ipk posted and run fine, thank you. cool
_________________________
Obsolete: Pioneer ECT-1530 - Kenwood DTF-103 - Sim2 SMB2700 - Philips 6072 - Humax 5400S - Dreambox 500S - NC+ 5800s BXZB E2

Dreambox DM500HD sim Japhar
Dreambox clone DM800HD sim 2.1
Estarbox DM800SE HD sim Japhar
Zgemma H9s

Top
#23207 - 03/18/21 01:12 AM Re: Openvpn client too old on latest japhar openpli [Re: Kenuser]
Admin Online   content
Japhar Member
Carpal Tunnel

Registered: 10/19/10
Posts: 9140
Yes, on the DM800HDse/DM500HD, as there is not much Flash Memory, OpenVPN is only available on the feeds, so you need to install with the "opkg update" and then "opkg install openvpn". I gave you the files, so you had them. The ipk on my post are from the feeds.

Admin
_________________________

Top



Moderator:  goodsat, Japhar, WarLord 
New Topics
DM7080HD : openvision-e2-extral
anguage-py210.2r385

by leovanderplaat
04/17/21 09:22 AM
DVB-T2/T/C chipsets
by EnoSat
04/11/21 10:27 AM
Openpli 4 problème ssl certificate
by otmane
04/10/21 02:45 PM
Problema caricamento immagine DM800HD pvr Japhar
by geronimoespa
04/10/21 01:12 PM
Firmware Lonrisun
by andyros
04/08/21 07:22 PM
Lista canales astra 19.2 y 23.5
by Anton70
04/07/21 03:47 PM
Upgrade DM800HDse to Japhar
by Anton70
03/31/21 05:27 PM
Nuovo iscritto
by Daniel Tekniko
03/28/21 05:59 AM
Carte Tivusat e canali visibili
by Toysoft
03/25/21 06:42 PM
Cloud Marketing Analytics for Dummies (PDF)
by Admin
03/22/21 09:34 AM
Kubernetes management for Dummies (PDF)
by Admin
03/22/21 09:32 AM
Wifi - RTL8811CU
by andyros
03/20/21 07:33 PM